import re
regex = re.compile(r"\b[a-zA-Z]{2}\w+[a-zA-Z]{3}\b", flags=re.MULTILINE)
test_str = "Please find the ref AB45676785567XYZ. which is used to identify reference number"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")