re = /\b[a-zA-Z]{2}\w+[a-zA-Z]{3}\b/m
str = 'Please find the ref AB45676785567XYZ. which is used to identify reference number'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end