import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([3]\\.[5]\\.([0-9]$|[1-9]\\d{1,}))|([3]\\.([6-9]|[1-9]\\d{1,})\\.\\d*)|(([4-9]|[1-9]\\d{1,})\\.\\d*\\.\\d*)";
final String string = "1.0.0\n"
+ "1.1.0\n"
+ "1.1.1\n"
+ "3.4.9\n"
+ "3.5.0\n"
+ "3.5.1\n"
+ "3.5.2\n"
+ "3.5.9\n"
+ "3.6.0\n"
+ "3.6.1\n"
+ "4.5.0\n"
+ "6.2.0\n"
+ "6.2.1\n"
+ "6.1.34\n"
+ "6.1.347\n"
+ "7.10.347\n"
+ "6.1.10\n"
+ "6.10.2\n"
+ "6.10.2\n"
+ "6.1.11\n"
+ "60.1.2\n"
+ "60.10.2\n"
+ "I am a string...\n"
+ "6.1.1234234\n"
+ "6.1.2\n"
+ "4.1.2\n"
+ "7..\n"
+ "05.34.35\n"
+ "0.15.54\n"
+ "6.1.13\n"
+ "94530.5435436.5435435\n"
+ "50.12.23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}