import Foundation
let pattern = #"([3]\.[5]\.([0-9]$|[1-9]\d{1,}))|([3]\.([6-9]|[1-9]\d{1,})\.\d*)|(([4-9]|[1-9]\d{1,})\.\d*\.\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.0.0
1.1.0
1.1.1
3.4.9
3.5.0
3.5.1
3.5.2
3.5.9
3.6.0
3.6.1
4.5.0
6.2.0
6.2.1
6.1.34
6.1.347
7.10.347
6.1.10
6.10.2
6.10.2
6.1.11
60.1.2
60.10.2
I am a string...
6.1.1234234
6.1.2
4.1.2
7..
05.34.35
0.15.54
6.1.13
94530.5435436.5435435
50.12.23
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)