const regex = /([3]\.[5]\.([0-9]$|[1-9]\d{1,}))|([3]\.([6-9]|[1-9]\d{1,})\.\d*)|(([4-9]|[1-9]\d{1,})\.\d*\.\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([3]\\.[5]\\.([0-9]$|[1-9]\\d{1,}))|([3]\\.([6-9]|[1-9]\\d{1,})\\.\\d*)|(([4-9]|[1-9]\\d{1,})\\.\\d*\\.\\d*)', 'gm')
const str = `1.0.0
1.1.0
1.1.1
3.4.9
3.5.0
3.5.1
3.5.2
3.5.9
3.6.0
3.6.1
4.5.0
6.2.0
6.2.1
6.1.34
6.1.347
7.10.347
6.1.10
6.10.2
6.10.2
6.1.11
60.1.2
60.10.2
I am a string...
6.1.1234234
6.1.2
4.1.2
7..
05.34.35
0.15.54
6.1.13
94530.5435436.5435435
50.12.23`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}