package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9_]+(?: *[+\/*-] *[a-zA-Z0-9_]+)*$`)
var str = `as + dfg - r_wer * rwer / r3r
r43 43rt43t 5rt
erte * rewtewt rrte`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}