import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9_]+(?: *[+\\/*-] *[a-zA-Z0-9_]+)*$";
final String string = "as + dfg - r_wer * rwer / r3r\n"
+ "r43 43rt43t 5rt\n"
+ "erte * rewtewt rrte";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}