// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<Linux>.*)(\w+\s+){2}").unwrap();
let string = "Google Chrome Verison 107.0.5304.110 Multiple Vulnerabilities";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}