const regex = /^\d+,[a-zA-Z0-9 ]+(?=,[a-zA-Z ]+,1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+,[a-zA-Z0-9 ]+(?=,[a-zA-Z ]+,1)', 'gm')
const str = `1351,Adanac St,North,2,2015
1375,Adanac St,North,1,2015
305,Alexander St,North,1,2012
320,Alexander St,South,2,2014
429,Alexander St,North,2,2015
475,Alexander St,North,2,2012
611,Alexander St,North,3,2015
200,Alexander St,North,2,2012
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}