import re
regex = re.compile(r"^\d+,[a-zA-Z0-9 ]+(?=,[a-zA-Z ]+,1)", flags=re.MULTILINE)
test_str = ("1351,Adanac St,North,2,2015\n"
"1375,Adanac St,North,1,2015\n"
"305,Alexander St,North,1,2012\n"
"320,Alexander St,South,2,2014\n"
"429,Alexander St,North,2,2015\n"
"475,Alexander St,North,2,2012\n"
"611,Alexander St,North,3,2015\n"
"200,Alexander St,North,2,2012\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")