re = /^\d+,[a-zA-Z0-9 ]+(?=,[a-zA-Z ]+,1)/m
str = '1351,Adanac St,North,2,2015
1375,Adanac St,North,1,2015
305,Alexander St,North,1,2012
320,Alexander St,South,2,2014
429,Alexander St,North,2,2015
475,Alexander St,North,2,2012
611,Alexander St,North,3,2015
200,Alexander St,North,2,2012
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end