$re = '/box(?=-shadow)/m';
$str = 'box-sizing
box-shadow
box-shadows
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;