import re
regex = re.compile(r"box(?=-shadow)", flags=re.MULTILINE)
test_str = ("box-sizing\n"
"box-shadow\n"
"box-shadows\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)