re = /box(?=-shadow)/m
str = 'box-sizing
box-shadow
box-shadows
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result