#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h+(?=\d)"
Local $sString = "1. B 2. E 3. E 4. D 5. E 6. A 7. A 8. E 9. E 10. D"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)