$re = '/\h+(?=\d)/m';
$str = '1. B 2. E 3. E 4. D 5. E 6. A 7. A 8. E 9. E 10. D';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;