use strict;
my $str = '1. B 2. E 3. E 4. D 5. E 6. A 7. A 8. E 9. E 10. D';
my $regex = qr/\h+(?=\d)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";