using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\w ]\().*(?=\))";
string input = @"foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa"")"" dsada)
h(dsaqwd)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}