re = /(?<=[\w ]\().*(?=\))/mx
str = 'foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
h(dsaqwd)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end