import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\w ]\\().*(?=\\))";
final String string = "foo(() ((hello) world))\n"
+ "bar (hello world!)\n"
+ "baz(ddd(()))\n\n"
+ "bazbaz(dsadsa\")\" dsada)\n\n"
+ "h(dsaqwd)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}