using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\p{Cyrillic}\S*)\h+(.+)";
string input = @"Куҷо дард мекунад? Show me where it hurts?
Нафас гиред / Нафас нагиред. Breath / Do not breath
Чуқуртар нафас гиред Breathe deeply";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}