re = /(.*\p{Cyrillic}\S*)\h+(.+)/m
str = 'Куҷо дард мекунад? Show me where it hurts?
Нафас гиред / Нафас нагиред. Breath / Do not breath
Чуқуртар нафас гиред Breathe deeply'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end