const regex = new RegExp('([£€$])?(?=(\\d{1,3}(?:,\\d{3})*(?:\\.\\d+)?(?![\\d.,])(?:\\s*(?:[tTbB]n|m|(?:[tT]r|[bBmM])illion)\\b)?)(\\s*(?:[pP](?:ence)?|[cC](?:ents?)?|€|[eE]uros?|[dD]ollars?|[pP]ounds?)\\b)?)(?(1)\\2(?!\\3)|(?<![£€$])\\2\\3)', 'g')
const str = `\$1 dollar ✘
1 ✘
\$1 tn dollars ✘
\$1,00000.000,000 ✘
1,000.00 ✘
\$1 ✓
1 pence ✓
1 cent ✓
1 euro ✓
1 dollar ✓
1 pound ✓
\$1 tn ✓
\$1 trillion ✓
1 trillion dollars ✓
\$1,000,000,000,000 ✓
\$1.000 ✓
\$1,000,000,000,000.000000 ✓
This sentence is worth 1 dollar, at least. More likely \$2 or \$3.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}