# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([£€$])?(?=(\d{1,3}(?:,\d{3})*(?:\.\d+)?(?![\d.,])(?:\s*(?:[tTbB]n|m|(?:[tT]r|[bBmM])illion)\b)?)(\s*(?:[pP](?:ence)?|[cC](?:ents?)?|€|[eE]uros?|[dD]ollars?|[pP]ounds?)\b)?)(?(1)\2(?!\3)|(?<![£€$])\2\3)"
test_str = ("$1 dollar ✘\n"
"1 ✘\n"
"$1 tn dollars ✘\n"
"$1,00000.000,000 ✘\n"
"1,000.00 ✘\n\n"
"$1 ✓\n"
"1 pence ✓\n"
"1 cent ✓\n"
"1 euro ✓\n"
"1 dollar ✓\n"
"1 pound ✓\n"
"$1 tn ✓\n"
"$1 trillion ✓\n"
"1 trillion dollars ✓\n"
"$1,000,000,000,000 ✓\n"
"$1.000 ✓\n"
"$1,000,000,000,000.000000 ✓\n\n"
"This sentence is worth 1 dollar, at least. More likely $2 or $3.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.