$re = '/([£€$])?(?=(\d{1,3}(?:,\d{3})*(?:\.\d+)?(?![\d.,])(?:\s*(?:[tTbB]n|m|(?:[tT]r|[bBmM])illion)\b)?)(\s*(?:[pP](?:ence)?|[cC](?:ents?)?|€|[eE]uros?|[dD]ollars?|[pP]ounds?)\b)?)(?(1)\2(?!\3)|(?<![£€$])\2\3)/';
$str = '$1 dollar ✘
1 ✘
$1 tn dollars ✘
$1,00000.000,000 ✘
1,000.00 ✘
$1 ✓
1 pence ✓
1 cent ✓
1 euro ✓
1 dollar ✓
1 pound ✓
$1 tn ✓
$1 trillion ✓
1 trillion dollars ✓
$1,000,000,000,000 ✓
$1.000 ✓
$1,000,000,000,000.000000 ✓
This sentence is worth 1 dollar, at least. More likely $2 or $3.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);