using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~~([\s\S]*?)~~(?!~)|~([^~]*)~";
string input = @"This is a demo paragraph with a wrapped string ~here~, with another string ~~here~~.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}