$re = '/~~([\s\S]*?)~~(?!~)|~([^~]*)~/m';
$str = 'This is a demo paragraph with a wrapped string ~here~, with another string ~~here~~.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);