using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?([A-HJ-NPRT-W]).*\1)[A-Z]+$";
string input = @"ABCDEFGHIJKLMNOPQRSTUVWXYZ
ABBA
AIIIQSXXXSXH";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}