$re = '/^(?!.*?([A-HJ-NPRT-W]).*\1)[A-Z]+$/m';
$str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ
ABBA
AIIIQSXXXSXH';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);