re = /^(?!.*?([A-HJ-NPRT-W]).*\1)[A-Z]+$/m
str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ
ABBA
AIIIQSXXXSXH'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end