#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d+(\.\d+)?$"
Local $sString = "-1234" & @CRLF & _
"543" & @CRLF & _
"51.23" & @CRLF & _
"-512.345612" & @CRLF & _
"-5.1-2" & @CRLF & _
"-5.-2" & @CRLF & _
"5.1.2" & @CRLF & _
"51foo51" & @CRLF & _
"foo1" & @CRLF & _
"1foo" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")