$re = '/^-?\d+(\.\d+)?$/m';
$str = '-1234
543
51.23
-512.345612
-5.1-2
-5.-2
5.1.2
51foo51
foo1
1foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);