package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?\d+(\.\d+)?$`)
var str = `-1234
543
51.23
-512.345612
-5.1-2
-5.-2
5.1.2
51foo51
foo1
1foo
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}