import re
regex = re.compile(r"""
{%\ for.*?%}
(?s:.+?)
{%\ endfor.*?%}
""", flags=re.VERBOSE)
test_str = ("{% for user in users %}\n"
" Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}\n"
"ssssssssssssssssssssss {{ user.name }}\n"
"sdsddddddddddddddddddddddddddddd\n"
"{% endfor %}\n\n"
"{% for dog in dogs %}\n"
" Your dog is {{ dog.age }} and likes {{ dog.food }}.\n"
"{% endfor %}\n"
"wwww\n"
"{{ user.name }}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")