re = /{%\ for.*?%}
(?s:.+?)
{%\ endfor.*?%}/x
str = '{% for user in users %}
Hello, {{ user.name }}, you are {{ user.age }} {{ user.name }}
ssssssssssssssssssssss {{ user.name }}
sdsddddddddddddddddddddddddddddd
{% endfor %}
{% for dog in dogs %}
Your dog is {{ dog.age }} and likes {{ dog.food }}.
{% endfor %}
wwww
{{ user.name }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end