const regex = new RegExp('(?<=\\dN)N+', 'gm')
const str = `20NNN (Expected Result: NN)
2NNN (Expected Result: NN)
2000NNNN (Expected Result: NNN)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}