re = /(?<=\dN)N+/m
str = '20NNN (Expected Result: NN)
2NNN (Expected Result: NN)
2000NNNN (Expected Result: NNN)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end