$re = '/(?<=\dN)N+/m';
$str = '20NNN (Expected Result: NN)
2NNN (Expected Result: NN)
2000NNNN (Expected Result: NNN)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);