package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z0-9]*?)([-_]?)([A-Z0-9]+\.SV)$`)
var str = `TRND-0LL2134.SV
TRN_RTXDFT.SV
TRND_ZRSFTFF.SV
DR3345.SV`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}