$re = '/^([A-Z0-9]*?)([-_]?)([A-Z0-9]+\.SV)$/m';
$str = 'TRND-0LL2134.SV
TRN_RTXDFT.SV
TRND_ZRSFTFF.SV
DR3345.SV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);