package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)((?:^|\n|;)\s*)export(.+)(?:as)?(\s*)default`)
var str = `export const test = '';
@Component
export class Foo {
/*default*
/}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}