re = /((?:^|\n|;)\s*)export(.+)(?:as)?(\s*)default/
str = 'export const test = \'\';
@Component
export class Foo {
/*default*
/}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end