package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\r?(-)\n`)
var str = `line 1
line 2-
line 3
line a-
line b
line c
`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}