$re = '/\r?(-)\n/ix';
$str = 'line 1
line 2-
line 3
line a-
line b
line c
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;