use strict;
my $str = 'line 1
line 2-
line 3
line a-
line b
line c
';
my $regex = qr/\r?(-)\n/ixp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";