import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<scheme>[^!$&'()*,;=@//:\\s]+):(?<authority>//(?<userinfo>(?<username>[\\w\\.\\-!$&'()*,;=]+):?(?<password>[\\w\\.\\-!$&'()*,;=]+)?@)?(?<host>[^\\s\\n\\t\\r/:\\[\\]]+|\\[[^\\s\\n\\t\\r/:\\[\\]]+\\]):?(?<port>\\d{1,5})?)?[/]?(?<path>[^\\s\\?#]{1,}(?:\\?(?<query>[^\\s#]+))?(?:#(?<fragment>[^\\s]+))?)?";
final String string = "example from wikipedia URI:\n"
+ " userinfo host port\n"
+ " ┌─┴─────┐\n"
+ " user pass\n"
+ " ┌──┴───────┴───┐┌──────┴──────┐ ┌┴─┐\n"
+ " https://john.doe:example@www.example.com:1234/forum/questions/?tag=networking&order=newest#top\n"
+ " └─┬─┘ └─────────────┬─────────────┘└───────┬───────┘ └────────────┬────────────┘ └┬┘\n"
+ " scheme authority path query fragment\n"
+ " userinfo host port\n"
+ " ┌──┴───┐ ┌──────┴──────┐ ┌┴─┐\n"
+ " https://john.doe@www.example.com:1234/forum/questions/?tag=networking&order=newest#:~:text=whatever\n"
+ " └─┬─┘ └─────────────┬─────────────┘└───────┬───────┘ └────────────┬────────────┘ └───────┬───────┘\n"
+ " scheme authority path query fragment\n\n"
+ " ldap://[2001:db8::7]/c=GB?objectClass?one\n"
+ " └┬─┘ └─────┬─────┘└─┬─┘ └──────┬──────┘\n"
+ " scheme authority path query\n\n"
+ " mailto:John.Doe@example.com\n"
+ " └─┬──┘ └────┬─────────────┘\n"
+ " scheme path\n\n"
+ " news:comp.infosystems.www.servers.unix\n"
+ " └┬─┘ └─────────────┬─────────────────┘\n"
+ " scheme path\n\n"
+ " tel:+1-816-555-1212\n"
+ " └┬┘ └──────┬──────┘\n"
+ " scheme path\n\n"
+ " telnet://192.0.2.16:80/\n"
+ " └─┬──┘ └─────┬─────┘│\n"
+ " scheme authority path\n\n"
+ " urn:oasis:names:specification:docbook:dtd:xml:4.1.2\n"
+ " └┬┘ └──────────────────────┬──────────────────────┘\n"
+ " scheme path";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}