#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bword1(?:[ \t]+\S+)*\W+word2\b.*?\s+(?=[^\d\s]*\d)(?=[^A-Z\s]*[A-Z])(?=[^a-z\s]*[\sa-z])\S{8,32}(?!\S)"
Local $sString = "word1 word2, abcABC123! blah blah" & @CRLF & _
"" & @CRLF & _
"word1 word2, abAC13! blah blah" & @CRLF & _
"" & @CRLF & _
"word1 test test test word2, abcABC123!kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk blah blah" & @CRLF & _
"" & @CRLF & _
"word1 test word2 test this is a test Supercalifragilisticexpialidocious abcABC123 Supercalifragilisticexpialidocious test" & @CRLF & _
"" & @CRLF & _
"word1 word2 abcABC123" & @CRLF & _
"" & @CRLF & _
"word1 #$%@%#% tst#@$# word2 ******************************* abcABC123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")