using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bword1(?:[ \t]+\S+)*\W+word2\b.*?\s+(?=[^\d\s]*\d)(?=[^A-Z\s]*[A-Z])(?=[^a-z\s]*[\sa-z])\S{8,32}(?!\S)";
string input = @"word1 word2, abcABC123! blah blah
word1 word2, abAC13! blah blah
word1 test test test word2, abcABC123!kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk blah blah
word1 test word2 test this is a test Supercalifragilisticexpialidocious abcABC123 Supercalifragilisticexpialidocious test
word1 word2 abcABC123
word1 #$%@%#% tst#@$# word2 ******************************* abcABC123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}