import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bword1(?:[ \\t]+\\S+)*\\W+word2\\b.*?\\s+(?=[^\\d\\s]*\\d)(?=[^A-Z\\s]*[A-Z])(?=[^a-z\\s]*[\\sa-z])\\S{8,32}(?!\\S)";
final String string = "word1 word2, abcABC123! blah blah\n\n"
+ "word1 word2, abAC13! blah blah\n\n"
+ "word1 test test test word2, abcABC123!kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk blah blah\n\n"
+ "word1 test word2 test this is a test Supercalifragilisticexpialidocious abcABC123 Supercalifragilisticexpialidocious test\n\n"
+ "word1 word2 abcABC123\n\n"
+ "word1 #$%@%#% tst#@$# word2 ******************************* abcABC123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}