import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ます|した|表現|彼";
final String string = "ある口の利けない人が歯ブラシを購入しようとしています。彼は、歯を磨くジェスチャーをして、店員にうまく伝える事ができたので目的の歯ブラシを買えました。次に、ある目の見えない人が、自分の目を隠すためにサングラスを買おうとしています。\n\n"
+ "問6 さて彼はどんな風に表現をすればうまく店員に伝わると思いますか。\n\n"
+ "目が見えない人にはもちろんステッキがあります。手を上げて、店員さんの注目を引きます。そして、店員さんがくる時直接サングラスが買いたいと言ってもいいです。\n\n"
+ "もしジェスチャーをしたいならば、目を閉じてまま眼鏡のジェスチャーをしてもいいです。\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}